Tag Archives: ATi

The Lich King Hates My Video Card

When I bought my new ASUS made ATi 4850 video card, the last thing I expected was to have problems with World of Warcraft.

I was worried that Lord of the Rings Online would overheat it, but I seem okay there.

I was worried that the graphics tweaks that came with Apocypha in EVE Online might slow it down, but I was covered.

But no, it is World of Warcraft, the game that runs on a toaster, that has issues.

And it isn’t even all of WoW.  I have been playing in old Azeroth quite a bit with my mom and daughter since the new video card showed up.  Every once in a while I noticed a stutter, a second or three of being frozen, but then things moved on.

No, it is Northrend that is killing me.

I figured this out when it looked like the instance group would return from its hiatus.  I had to get Vikund out to make sure I remembered how to play him.  He was parked in Northrend.  In Dalaran.

Log in.  Move several feet.  Freeze up.  Hrmm.

Log in.  Move several feet.  Freeze up.  Maybe one of those addons?

Turn off addons.

Log in.  Just Freeze up.  Okay.

Reboot.

Log in.  Move a few more feet.  Freeze up.

Okay, I know Dalaran is the new Ironforge lag city.  Maybe if I can just get out of the place.

Reboot.

Log in.  Don’t touch anything for a minute.  Move half way to the flight point.  Freeze up.  Scream.

Eventually I gave up.

I went over to our iMac.  Logged in.  Ran around Dalaran just fine.

I got out my laptop with its tiny ATi x300 mobile video card.  Logged in.  Ran around Dalaran with a lot of lag, but never froze.

I put Vikund in Stormwind and started looking into the problem.

I searched Google with the phrase “4850 WoW Crash.”  Lots of results.  I do not appear to be alone.  Of course, theories vary on the cause.  It could be the ATi drivers, the firmware, my motherboard, the anti-aliasing settings, Blizzard’s bad code, sun spots, or the Illuminati.

I found a couple of unhelpful threads in the Blizzard forums.  Well, a lot, actually.  Welcome to game forums.  I did find their system performance guide though, and it has a few things I can try fiddling with.

And ATi put out a new set of drivers last week.  I can give that a try.

But I have to get this figured out by Saturday night or I’ll be playing on the iMac.  Not that playing on the iMac is a bad thing, but it is out in the family room, close enough to the TV that I will probably annoy my wife.

I probably should have run that Google search BEFORE I bought the card.  Ah well.